Skip to content

HCL Digital Experience 9.5 for Express detailed system requirements

This document provides minimum system requirements for version [9.5] release of [HCL Digital Experience for Express 9.5]. Higher maintenance levels, such as fix packs and service packs, may be supported as they become available and will be updated in this document, and some may be made available through HCL channels. For detailed system requirements of other HCL Digital Experience offerings, see: System Requirements. Detailed system requirements are the complete lists of hardware requirements, supported operating systems, prerequisites and optional supported software, with component-level details and operating system restrictions.

System requirements


Last update: September 12, 2022