Databases

Supported Software Version Supported software minimum Product minimum Components Operating System Restrictions?
Apache Derby 10.11* and future fix packs 10.11*
Newer levels are not currently supported
9.5 Full No
DB2 Standard and Advanced Edition 11.5 11.5 and later maintenance 9.5 Full No
DB2 Advanced Enterprise Server Edition 11.1.0* 11.1.0 and later maintenance 9.5 Full No
DB2 Advanced Workgroup Server Edition 11.1.0* 11.1.0 and later maintenance 9.5 Full No
DB2 Connect Application Server Advanced Edition 11.1.0 11.1.0 and later maintenance 9.5 Full No
DB2 Connect Enterprise Edition 11.1.0 11.1.0 and later maintenance 9.5 Full No
DB2 Enterprise Server Edition 11.1.0 11.1.0 and later maintenance 9.5 Full No
DB2 Express Edition 11.1.0 11.1.0 and later maintenance 9.5 Full No
DB2 for z/OS 11.1.0 11.1.0 and later maintenance 9.5 Full No
Microsoft SQL Server 2014 2014 and later maintenance 9.5 Full No
2016 2016 and later maintenance 9.5 Full No
Microsoft SQL Server Enterprise and Standard Edition 2017 and 2019 2017, 2019 and later maintenance 9.5 Full No
Oracle Database 12.2 Standard Edition (12.2.0.0) (12.2.0.0) and later maintenance 9.5 Full No
Oracle Database 12.2 Enterprise Edition (12.2.0.0) (12.2.0.0) and later maintenance 9.5 Full No
Oracle Database 12.2.0.1.0 Enterprise Edition 12.2.0.1.0 12.2.0.1.0 and later maintenance 9.5 Full No
Oracle Database 12.2.0.2 Enterprise Edition 12.2.0.2 12.2.0.2 and later maintenance 9.5 Full No
Oracle Database 19c 19c 19c and later maintenance 9.5 Full No
Oracle on Amazon Relational Database Service 12.2.0.1.0 12.2.0.1.0 and later maintenance 9.5 Full No

* Apache Derby is not supported in a product environment.
* DB2: Includes support for DB2 pureScale component.


Last update: September 12, 2022